Delay on provisioning request processing due delays on Atlassian's webhooks delivery

Incident Report for Multiplier

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 18:17 PDT

Monitoring

The issue seems to be resolved, we'll keep monitoring.
Posted Jun 30, 2026 - 18:15 PDT

Investigating

We are noticing a delay on webhook delivery by Atlassian, which causes delays on software provisioning request processing. Our investigation shows delays of 10-20 minutes. We are reaching out to Atlassian to additional information on the webhook delivery delays.
Posted Jun 30, 2026 - 15:52 PDT
This incident affected: Multiplier Jira App and Slack App.